

<!DOCTYPE html>

<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">

<head> 

  <meta charset="utf-8">

  <meta name="viewport" content="width=device-width, initial-scale=1">

  <meta http-equiv="Content-Type" content="text/html">

  <title>Snow showers to continue through Saturday in Williams | Grand Canyon News | Grand Canyon, AZ</title>

  

  


  
    
      
        <meta name="__sync_contentCategory" content='Free' />
        <meta name='__sync_tenantId' content='wn_wgcn'>
      
    
  
    
  


  

  <meta property="fb:app_id" content="1918757495038545" /> 

  <meta property="og:title" content="Snow showers to continue through Saturday in Williams">

  <meta property="og:type" content="article">

  <meta property="og:url" content="https://www.grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/">

  <meta property="og:description" content="Additional snow accumulations of 1 to 4 inches is expected with localized amounts up to 6 inches.">

  

  <meta property="og:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/12/27/snow_3861.jpg" />

  

  <meta property="og:site_name" content="Grand Canyon News">

  <meta name="twitter:title" content="Snow showers to continue through Saturday in Williams">

  

  <meta name="twitter:card" content="summary_large_image">

  <meta name="twitter:site" content="@www.grandcanyonnews.com">

  <meta name="twitter:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/12/27/snow_3861.jpg">

  

  

  <meta name="twitter:description" content="Additional snow accumulations of 1 to 4 inches is expected with localized amounts up to 6 inches.">

  

  <meta name="twitter:widgets:csp" content="on">



  

  <link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/print.css?v=18" type="text/css" media="print">

  <link  href="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.css" rel="stylesheet">

  <!--[if IE 6]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->

  <!--[if IE 7]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->

<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.css">

<link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dist/css/main.min.css?v=299" type="text/css">



<script

  src="https://code.jquery.com/jquery-3.3.1.min.js"

  integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8="

  crossorigin="anonymous"></script>



  

  <link rel="icon" type="image/x-icon" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/grandcanyonnews/logos/gcn_favicon1.png" sizes="32x32">

  <link rel="icon" type="image/png" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/grandcanyonnews/logos/gcn_favicon1.png" sizes="32x32">



  <script type="text/javascript">

    var STATIC_MEDIA_URL = 'https://westernnews.media.clients.ellingtoncms.com/static-3/';

  </script>

  <script src="https://polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/lozad.min.js"></script>

  <script src="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/js-cookie.js"></script>

  <script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?key=AIzaSyAPfAD5-v4cObqJcVA7x5izMVPKJ-Q-qds" ></script>


  

<script>

  var syncPaymeter = {

    onLoad: function(meter){

      meter.events.registerHandler(meter.events.onAuthorizeSuccess,

        function(ctx){

          document.getElementById('flipp-overlay').style.display = 'none';

          document.getElementById('circularhub_module_2889').style.display = 'block'; 

           console.log('++++++++++++++++++++++ Authorization Success ' + ctx.statusMsg); 

        });

      meter.events.registerHandler(meter.events.onWallFired,

        function(ctx){

           console.log('++++++++++++++++++++++ Wall Fired ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onSessionStarting,

        function(ctx){

           console.log('++++++++++++++++++++++ Session Starting');

        });

      meter.events.registerHandler(meter.events.onSessionStarted,

        function(ctx){

           console.log('++++++++++++++++++++++ Session Started');

        });

      meter.events.registerHandler(meter.events.onSessionSaving,

        function(ctx){

           console.log('++++++++++++++++++++++ Session Saving');

        });

      meter.events.registerHandler(meter.events.onSessionSaved,

        function(ctx){

           console.log('++++++++++++++++++++++ Session Saved ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onAuthorizeStarting,

        function(ctx){

           console.log('++++++++++++++++++++++ Authorization Starting');

        });

      meter.events.registerHandler(meter.events.onAuthorizeFailed,

        function(ctx){

           console.log('++++++++++++++++++++++ Authorization FAILED ' + ctx.statusMsg);

        });

      meter.events.registerHandler(meter.events.onServerError,

        function(ctx){

           console.log('++++++++++++++++++++++ SERVER ERROR ' + ctx.statusMsg);

        });

    }

  };

</script>

<script type="text/javascript" src="https://subscribe.williamsnews.com/wn/wgcn/api/scripts/syncwall"></script>



  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.js"></script>

  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/momentjs/moment.min.js"></script>

  

  <link type="application/rss+xml" rel="alternate" href="/rss/headlines/">

  

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>

<script>

  var googletag = googletag || {};

  googletag.cmd = googletag.cmd || [];

</script>

  

<script>

  googletag.cmd.push(function() {

    var desktopMapping = googletag.sizeMapping().

      addSize([768, 0], [[989, 150], [728,90], [300, 600], [300, 250]]).

      addSize([0, 0], []).

      build();

    var mobileMapping = googletag.sizeMapping().

      addSize([768, 0], []).

      addSize([0, 0], [[320, 50], [300, 250], [310, 310]]).

      build();

    googletag.defineSlot('/187193454/gcn_lb_atf', [[989, 150], [728, 90]], 'div-gpt-ad-1478282699440-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_lb_btf', [[989, 150], [728, 90]], 'div-gpt-ad-1478282699440-1').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_hp_top_lb', [[989, 150], [728, 90]], 'div-gpt-ad-1552417544092-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_rr_1', [[300, 250], [300, 600]], 'div-gpt-ad-1473351531487-9').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_rr_2', [[300, 250], [300, 600]], 'div-gpt-ad-1473351531487-10').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_rr_3', [[300, 250], [300, 600]], 'div-gpt-ad-1473351531487-11').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_hp_medrec_1', [300, 250], 'div-gpt-ad-1552417820204-0').addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_hp_medrec_2', [300, 250], 'div-gpt-ad-1552417944004-0').addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_mb', [320, 50], 'div-gpt-ad-1473351531487-3').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_mb_footer', [310, 310], 'div-gpt-ad-1473351531487-4').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/187193454/gcn_mb_ict', [300, 250], 'div-gpt-ad-1475104850690-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.pubads().collapseEmptyDivs(true);

    googletag.enableServices();

  });

</script>



  

  

  

</head>

<body class="news story_detail revision" id="story_53633">

  <div class="ui top sidebar vertical menu top-more-menu">

    

  <div class="ui centered aligned page grid">

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

  <div class="five column row">

    <div class="column">

      <div class="item">

        <div class="header">OFFERS</div>

      </div>

      <a class="item top-more-menu-item" href="https://www.retailmenot.com/everyday">RetailMeNot Everyday</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.circularhub.com/?p=wgcn">This Week's Circulars (Flipp)</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>

      <a href="/purchase-photo/" class="item top-more-menu-item">Purchase a Photo</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">SUBMISSIONS</div>

      </div>

      <a class="item top-more-menu-item" href="/submit/g/">General Submissions</a>

      <a class="item top-more-menu-item" href="https://classifiedsplacement.westernnews.com/williamsnewsui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a>

      <a class="item top-more-menu-item" href="/subscriber-services/index/">Subscriber Services (Start / Stop)</a>

      <a class="item top-more-menu-item" href="/submit-event/">Submit Event</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">MEDIA</div>

      </div>

      <a class="item top-more-menu-item" href="/pre-website-archives/">Archives: Pre-Web</a>

      <a class="item top-more-menu-item" href="/users/newsletters/">Newsletter</a>

      <a class="item top-more-menu-item" href="/other-publications/">Other Publications</a>

      <a class="item top-more-menu-item" href="/photos/galleries/">Photo Galleries</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">COMMUNITY</div>

      </div>

      <a class="item top-more-menu-item" href="/about/">About Us</a>

      <a class="item top-more-menu-item" href="/discovery-map/">Discovery Map</a>

      <a class="item top-more-menu-item" href="/events/2019/dec/">Event Calendar</a>

      <a class="item top-more-menu-item" href="http://www.grandcanyontourguide.com/grand-canyon">Grand Canyon Tour Guide</a>

    </div>

    <div class="column">

      <a href="https://cloud.3dissue.com/153878/158184/library.html" class="item"><div class="ui positive button">e-Edition</div></a>

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input"  autocomplete="off" _lpchecked="1">

          <input type="text" name="q" placeholder="Search..." value="">

          <i class="search icon"></i>

        </form>

      </div>

    </div>

  </div>

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

</div>



  </div>

  <div class="ui left vertical inverted menu sidebar sidebar-nav">

    

  <div class="item">
  <a href="/news/news/" class="header">NEWS</a>
</div>
<div class="item">
  <a href="/news/opinion/" class="header">OPINION</a>
</div>
<div class="item">
  <a href="/news/sports/" class="header">SPORTS</a>
</div>
<div class="item">
  <a href="/news/features/" class="header">FEATURES</a>
</div>
<div class="item">
  <a href="/news/environment/" class="header">ENVIRONMENT</a>
</div>
<div class="item">
  <a href="/news/obituaries/" class="header">OBITUARIES</a>
</div>
<div class="item">
  <a href="/classifieds/" class="header">CLASSIFIEDS</a>
</div>
<div class="item">
  <a href="/contact-us/" class="header">CONTACT</a>
</div>
<div class="item">
  <a href="https://cloud.3dissue.com/153878/158184/library.html" class="header">E-EDITION</a>
</div>
<div class="item">
  <div class="header">MORE</div>
    <div class="menu">
      <a class="item" href="/about/">About Us</a>
      <a class="item" href="/discovery-map/">Discovery Map</a>
      <a class="item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>
      <a class="item" href="/pre-website-archives/">Archives: Pre-Web</a>
      <a class="item" href="/users/newsletters/">Newsletter</a>
      <a class="item" href="/events/2019/dec/">Event Calendar</a>
      <a class="item" href="/other-publications/">Other Publications</a>
      <a class="item" href="/photos/galleries/">Photo Galleries</a>
      <a class="item" href="https://classifiedsplacement.westernnews.com/williamsnewsui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a>
      <a href="/purchase-photo/" class="item">Purchase a Photo</a>
      <a class="item" href="https://www.retailmenot.com/everyday">RetailMeNot Everyday</a>
      <a class="item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>
      <a class="item" href="/submit/g/">General Submissions</a>
      <a class="item" href="/subscriber-services/">Subscriber Services (Start / Stop)</a>
      <a class="item" target="_blank" href="http://www.circularhub.com/?p=wgcn">This Week's Circulars (Flipp)</a>
    </div>
</div>
 



  </div>

  <div class="pusher">

    

    <script>

      dataLayer = [];

      var observer = lozad('.lozad', {

        rootMargin: '500px 0px',

        threshold: 0.1

      });

    </script>

    

  
    
      
          
            <script>
              var category = 'News';
              dataLayer.push({
                'contentGroup1': category,
                'dimension1': category
              });
           </script>
          
      
    
      
    




    

<!-- Google Tag Manager -->

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TC6C85"

height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-TC6C85');</script>

<!-- End Google Tag Manager -->

 

    

<script type="text/javascript">

(function() {

  var ARTICLE_URL = window.location.href;

  var CONTENT_ID = 'everything';

  document.write(

    '<scr'+'ipt '+

    'src="//survey.g.doubleclick.net/survey?site=_crmqjzwlysu45tczhxu7mfxgky'+

    '&amp;url='+encodeURIComponent(ARTICLE_URL)+

    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+

    '&amp;random='+(new Date).getTime()+

    '" type="text/javascript">'+'\x3C/scr'+'ipt>');

})();

</script>



    

<script>

  window.fbAsyncInit = function() {

    FB.init({

      appId      : '1918757495038545',

      xfbml      : true,

      version    : 'v2.9'

    });

    FB.AppEvents.logPageView();

  };

  (function(d, s, id){

     var js, fjs = d.getElementsByTagName(s)[0];

     if (d.getElementById(id)) {return;}

     js = d.createElement(s); js.id = id;

     js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9&appId=1918757495038545";

     fjs.parentNode.insertBefore(js, fjs);

   }(document, 'script', 'facebook-jssdk'));

</script>



    

  <div id="main-navigation" class="ui inverted menu no-margin grandcanyonnews">
  <div class="ui container inverted menu borderless main-nav-items grandcanyonnews">
    <a href="/" class="item" id="navbar-logo-link">
      <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/grandcanyonnews/logos/nav-logo-3.png" alt="Grand Canyon News logo" class="ui image small" id="navbar-logo">
    </a>
    <div class="ui simple dropdown item hide-main-nav">
      <a href="/news/news/">NEWS</a>
    </div>
    <div class="ui simple dropdown item hide-main-nav">
      <a href="/news/opinion/">OPINION</a>
    </div>
    <div class="ui simple dropdown item hide-main-nav">
      <a href="/news/sports/">SPORTS</a>
    </div>
    <div class="ui simple dropdown item hide-main-nav">
      <a href="/news/features/">FEATURES</a>
    </div>
    <div class="ui simple dropdown item hide-main-nav">
      <a href="/news/environment/">ENVIRONMENT</a>
    </div>
    <a href="/news/obituaries/" class="item hide-main-nav">OBITUARIES</a>
    <a href="/classifieds/" class="item hide-main-nav">CLASSIFIEDS</a>
    <div class="item menu dropdown more-menu hide-main-nav">MORE <i class="dropdown icon"></i></div>
    <div id="nav-search-trigger" class="item menu dropdown">
      <i class="inverted search icon"></i>
    </div>
    <div id="navbar-search" class="ui form">

      <form action="/search/vertical/news.story/" method="get" autocomplete="off" id="search-form">

        <div class="ui icon input">

          <input type="text" name="q" value="" id="nav-search-input" class="nav-search-input" placeholder="Search...">

            <i class="circular search link icon"></i>

        </div>

      </form>

    </div>
    <script>
      var form = document.getElementById('search-form');
      form.addEventListener('submit', function(e) {
        e.preventDefault();
        var input = document.getElementById('nav-search-input');
        var sort = input.value + '&sortby=date';
        window.location = "/search/vertical/news.story/?q=" + sort;
      });
    </script>

    <div class="ui simple dropdown item">

      <a id="sync-login-status" class="log-in" href="https://subscribe.williamsnews.com/wn/wgcn/account/logon?ReturnUrl=https://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/"></a>

      <a id="sync-login-myaccount" href="https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=WGCN"></a>
      <div class="ui inverted menu" id="logoutContainer">
        <div class="item">
          <div id="btnLogout" class="ui negative button">Log Out</div>
        </div>
      </div>

    </div>

    <div id="side-nav-button" class="ui simple dropdown item show-side-nav-button">

      <i class="sidebar icon"></i>

      Menu

    </div>

  </div>

</div>

<script>

  var search = document.getElementById('nav-search-trigger');

  var form =  document.getElementById('navbar-search');

  var input = document.getElementById('nav-search-input');

  search.addEventListener('click', function(e) {

    form.style.zIndex = 1;

    input.classList.toggle('nav-search-animation');

    input.focus();

  });

  input.addEventListener('blur', function(e) {

    this.classList.remove('nav-search-animation');

    form.style.zIndex = -1;

  });

</script> 



    <div id="page" class="ui container">

      

      

<div id="mobile-subscribe" class="has-text-centered is-shown-mobile top-margin-one-rem">
  <a href="https://subscribe.williamsnews.com/Wn/wgcn/Account/AvailableSubscriptions"><h3 class="ui blue header">Subscribe Now</h3></a>
</div>

<div class="brand-header is-hidden-mobile flex items-center justify-between">

  <div class="brand-main-logo">

    

    <a href="/"><img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/grandcanyonnews/logos/logo.jpg" alt="Grand Canyon News Logo"></a>

    

  </div>

  <div class="has-text-centered">

    <a href="https://subscribe.williamsnews.com/Wn/wgcn/Account/AvailableSubscriptions" class="inline-block right-margin-one-rem hidden" id="subscribe-now">

    <div class="has-text-centered">

      <span class="ui blue header">Subscribe Now</span><br>

    </div>

    </a> 

    

      <a href="/e-edition/"><button class="ui basic primary button e-edition-button">e-Edition</button></a>

    

  </div>

</div>

<div class="toolbar-header is-hidden-mobile flex justify-between items-center">

  <div class="toolbar-item hide-toolbar-item-medium">

    Trusted local news leader for the Grand Canyon

  </div>

  <span class="item-divider hide-toolbar-item-medium"></span>

  <div class="toolbar-item">

    Fri, Dec. 27

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    

     <a href="/weather/">Weather &nbsp;26.0 <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/images/weather/small/snow.gif" height="15" width="15" alt="weather icon"></a>

    

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/subscriber-services/index/">Subscriber Services</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact-us/">Contact Us</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact/">News Tips</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="https://www.facebook.com/GrandCanyonNews/">  <i class="large facebook icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://twitter.com/GCanyonNews"> <i class="large twitter square icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://www.youtube.com/user/GrandCanyonNews"> <i class="large youtube square icon" aria-hidden="true"></i></a>

  </div>

</div>



      

      

      <div class="breadcrumbs">

        

      </div>

      

      <div id="body">

        <div class="wrapper">

          

            

            

            

            

              <div class="content_title">

                


              </div>

            

            

            

            

              

              <div class="page-content">

                

                

                  

                    

                  

                

                



  
    
      
          
            <script>
              var category = 'News';
              dataLayer.push({
                'contentGroup1': category,
                'dimension1': category
              });
           </script>
          
      
    
      
    




<div class="story">
  <div class="bottom-margin-two-rem">
    <div class="flex justify-center">

      <!-- /187193454/gcn_hp_top_lb -->
<div id='div-gpt-ad-1552417544092-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1552417544092-0'); });
</script>
</div>

    </div>

    <div class="flex justify-center">

      <!-- /187193454/gcn_mb -->

<div id='div-gpt-ad-1473351531487-3' style='height:50px; width:320px; margin:10px auto;'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1473351531487-3'); });

</script>

</div>

    </div>
  </div>
  <div class="ui equal width grid">

    <div class="column story-column ">

      <div class="ui text container">
        

          <h1 class="ui medium header">

          Snow showers to continue through Saturday in Williams

          

          </h1>

        
        

        

          <div class="story__lead-photo">

            <div class="ui bottom attached segment">

              <div class="photo">

                

                <a href="/photos/2019/dec/27/43438/"><img src="https://westernnews.media.clients.ellingtoncms.com/img/photos/2019/12/27/snow_3861_t715.jpg?529764a1de2bdd0f74a9fb4f856b01a9d617b3e9" alt="Snow continues to fall from a winter storm that started Dec. 24. (Photo/WGCN)" class="img-responsive"></a>

                

              </div>

              <div class="lead-photo-info">

                

                <p class="caption">

                  Snow continues to fall from a winter storm that started Dec. 24. (Photo/WGCN)

                </p>

              </div>

            </div>

          </div>

        

        

        <div class="article-info">

          

<div class="has-text-centered">

    

</div>

<div class="has-text-centered article-info__item">

  

    By 

      <a href="/staff/williams-grand-canyon-news/">Williams-Grand Canyon News</a>

        

      

    

  

  

    

  

</div>

<div class="has-text-centered article-info__item">

  <div class="article-published">Originally Published: December 27, 2019 8:45 a.m.</div>

  

    <p class="article-published">

      

    </p>

  

</div>

<div class="flex justify-center items-center">

  <div class="sharing-icon fb-share-button" data-href="https://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/" data-layout="button"></div>

  <div class="sharing-icon troublemaker-sharing-icon"><a class="twitter-share-button" href="https://twitter.com/intent/tweet">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></div>

  <div class="sharing-icon" onclick="window.print()"><i class="print icon print-icon troublemaker-sharing-icon"></i></div>

  <div class="sharing-icon"><a href="mailto:?subject=Snow showers to continue through Saturday in Williams&body=https://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/"><i class="envelope outline icon troublemaker-sharing-icon"></i></a></div>

</div>


        </div>

        <div class="ui divider less-margin"></div>


        

        <div id="overlay">

          <div id="overlay-content">

            <div id='sync-inline-overlay'>

              <div class="story_body" id="target-story_body_template" >

                <div class="inline text_inline inline-right  ui segment" >

  <h4 class="title">Additional snow forecast from 2 a.m. to 5 p.m. Dec. 28</h4>

  <p>Williams - 3 to 5  inches</p>

<p>Doney Park - 1 to 3  inches</p>

<p>Flagstaff - 2 to 4  inches</p>

<p>Sedona - 1 to 2  inches</p>

</div>



<p>WILLIAMS, Ariz. – Additional snow accumulations of 1 to 4 inches is expected with localized amounts up to 6 inches for areas near Doney Park, Flagstaff, Sedona and Williams Dec. 27-28, according to the National Weather Service. </p>

<p>Snow will continue to accumulate above 5,000 feet, falling as low as 4,000 feet in heavier showers through Saturday. Travelers throughout northern and central Arizona should be prepared for snow and winter weather driving conditions through Saturday afternoon.</p>

<p>Temperatures will reach a high of 33 degrees today in Williams. Tonight, expect mostly cloudy conditions with a low around 17. New snow accumulation tonight is expected to be less than one inch overnight.</p>

<p>Saturday, there is a 10 percent chance of snow showers before 11 a.m. It is expected to be sunny, with a high near 29 and a northwest wind of 5 to 11 mph late Saturday. </p>

<p>The latest road conditions for the state you are calling from can be obtained by calling 5 1 1.</p>

                

                

              </div> 

            </div>

          </div> 

        </div> 

        

        









<div class="ui compact fluid five item menu story-tools">

  

  <a href="/contact/" class="item">Contact</a>

    

  <a href="/mailfriend/155/53633/df8f0e9807/" rel="popup(620x650)" class="item"><i class="large envelope outline icon"></i></a>

  <a href="https://www.facebook.com/sharer.php?u=http://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/" target="new" class="item"><i class="large facebook icon"></i></a>

  <a href="http://twitter.com/home?status=http://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/" class="item"><i class="large twitter icon"></i></a>

  <a href="javascript:void(0)" class="item print-icon" onclick="window.print()"><i class="large print icon"></i></a>      

  

</div>





        <div class="fluid ui grey button top-margin-one-rem newsletter">Sign up for Grand Canyon News e-News Alerts</div>

        <div class="ui grey segment most-read">

<div class="ui header">Most Read</div>

	<div class="ui top attached tabular menu">

		<div class="item active" data-tab="sevendays">7 days</div>

		<div class="item" data-tab="thirtydays">30 days</div>

	</div>

	<div class="ui bottom attached tab segment active" data-tab="sevendays">
	    <ul id="tab-content1"class="ui relaxed list">
		<li class="item"><a href="/news/2019/dec/24/grand-canyon-receive-4-inches-snow-dec-24/">Grand Canyon to receive up to 4 inches of snow Dec. 24 </a></li>
		<li class="item"><a href="/news/2019/dec/23/new-zealand-mudsnails-infest-page-springs-fish-hat/">New Zealand mudsnails infest Page Springs Fish Hatchery </a></li>
		<li class="item"><a href="/news/2019/nov/29/grand-canyon-village-without-power-some-roads-clos/">Update: Grand Canyon Village still without power, some roads closed </a></li>
		<li class="item"><a href="/news/2019/nov/26/snow-blankets-grand-canyon-more-way/">Snow blankets Grand Canyon, more on the way </a></li>
		<li class="item"><a href="/news/2019/dec/17/gallery-31-children-available-adoption-arizona/">Gallery: 31 children available for adoption in Arizona </a></li>
		<li class="item"><a href="/news/2019/oct/17/grand-canyons-south-rim-returns-normal-water-opera/">Grand Canyon's South Rim returns to normal water operations </a></li>
		<li class="item"><a href="/news/2019/dec/10/looking-christmas-cheer-celebrate-holidays-canyon-/">Looking for Christmas cheer: Celebrate the holidays Canyon-style </a></li>
		<li class="item"><a href="/news/2019/nov/12/couples-deaths-grand-canyon-remain-unsolved/">Couple's deaths in Grand Canyon remain unsolved </a></li>
		<li class="item"><a href="/news/2018/jan/23/how-dangerous-state-route-64/">How dangerous is State Route 64? </a></li>
		<li class="item"><a href="/news/2019/dec/10/body-man-who-drowned-creek-found-fourth-die-there-/">Body of man who drowned in creek found; fourth to die there this month </a></li>
</ul>
    	</div>
    	<div class="ui bottom attached tab segment" data-tab="thirtydays">
	    <ul id="tab-content2"class="ui relaxed list">
		<li class="item"><a href="/news/2019/nov/29/town-tusayan-declares-state-emergency-due-snow-lac/">Town of Tusayan declares state of emergency due to snow, lack of electricity </a></li>
		<li class="item"><a href="/news/2019/nov/29/grand-canyon-village-without-power-some-roads-clos/">Update: Grand Canyon Village still without power, some roads closed </a></li>
		<li class="item"><a href="/news/2019/nov/26/snow-blankets-grand-canyon-more-way/">Snow blankets Grand Canyon, more on the way </a></li>
		<li class="item"><a href="/news/2019/nov/12/couples-deaths-grand-canyon-remain-unsolved/">Couple's deaths in Grand Canyon remain unsolved </a></li>
		<li class="item"><a href="/news/2019/nov/30/power-restored-tusayan-and-grand-canyon/">Power restored to Tusayan and Grand Canyon </a></li>
		<li class="item"><a href="/news/2019/nov/25/hiker-found-dead-zion-national-park-was-concession/">Hiker found dead in Zion National Park was concession worker </a></li>
		<li class="item"><a href="/news/2019/nov/26/3-outfitter-guides-convicted-banned-arizona-forest/">3 outfitter guides convicted, banned from Arizona forests </a></li>
		<li class="item"><a href="/news/2019/dec/24/grand-canyon-receive-4-inches-snow-dec-24/">Grand Canyon to receive up to 4 inches of snow Dec. 24 </a></li>
		<li class="item"><a href="/news/2019/nov/27/williams-facing-23-inches-snow-storm-expected-than/">Williams facing up to 23 inches of snow as storm expected Thanksgiving Day </a></li>
		<li class="item"><a href="/news/2019/oct/17/grand-canyons-south-rim-returns-normal-water-opera/">Grand Canyon's South Rim returns to normal water operations </a></li>
</ul>
    	</div>

</div>



        

        

        

        <div class="ui segment has-text-centered more-like-this"> 

          <h3>More like this story</h3>        

          

            <div class="item"><a href="/news/2019/dec/24/grand-canyon-receive-4-inches-snow-dec-24/" class="blue-link">Grand Canyon to receive up to 4 inches of snow Dec. 24</a></div>

          

            <div class="item"><a href="/news/2019/dec/27/grand-canyon-under-winter-weather-advisory-snow-sh/" class="blue-link">Grand Canyon under winter weather advisory as snow showers continue</a></div>

          

            <div class="item"><a href="/news/2018/dec/31/winter-storm-bring-snow-and-cold-temps-williams-gr/" class="blue-link">Dec. 31, 5 p.m. update: Winter storm to bring snow and cold temps to Williams, Grand Canyon</a></div>

          

            <div class="item"><a href="/news/2012/apr/14/winter-weather-advisory-in-effect-until-4-pm-apri/" class="blue-link">Winter weather advisory in effect until 4 p.m., April 14</a></div>

          

            <div class="item"><a href="/news/2009/dec/30/travel-advisory-in-effect-for-northern-arizona/" class="blue-link">Travel advisory in effect for northern Arizona</a></div>

          

        </div>

        


        

        <div class="ui segment has-text-centered submit-feedback">

          <h3>SUBMIT FEEDBACK</h3>

          <p>Click Below to:</p>

          <div><a href="/submit/rants-and-raves/" class="blue-link">File a Rant or Rave about this story</a></div>

          <div><a href="/contact/" class="blue-link">Ask us a question</a></div>

          <div><a href="/submit/letter-to-the-editor/" class="blue-link">Submit a letter to the editor</a></div>

          <div><a href="/contact/" class="blue-link">Send us a news tip or story idea</a></div>

        </div>

      </div>

    </div>

    

    <div class="six wide column is-hidden-touch">

      <div class="right-rail">

  <div class="flex justify-center google-ads">

    <!-- /187193454/gcn_rr_1 -->

<div id='div-gpt-ad-1473351531487-9' style='margin:10px auto; text-align:center;'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1473351531487-9'); });

</script>

</div>

  </div>

  <div class="flex justify-center google-ads">

    <!-- /187193454/gcn_rr_2 -->

<div id='div-gpt-ad-1473351531487-10' style="margin:10px auto; text-align:center;">

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1473351531487-10'); });

</script>

</div>

  </div>

  <div class="flex justify-center google-ads">

    <!-- /187193454/gcn_rr_3 -->

<div id='div-gpt-ad-1473351531487-11' style='margin:10px auto; text-align:center;'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1473351531487-11'); });

</script>

</div>

  </div>

  

    

  

<div class="calendar-tease">

  <div class="ui segment">
    <div class="ui header">Event Calendar</div>
    <a href="/events/2019/dec"><img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/images/calendar3.jpg" class="img-responsive" alt="Event Calendar link"></a>
    <a href="/submit-event/">

      <div class="positive ui button"><i class="plus icon"></i> Submit Event</div>

    </a>

  </div>

  

</div>


  

  

    <div id="circularhub_module_2889"></div>



<script src="//api.circularhub.com/2889/9b4bf6808467a10b/flyertown_module.js"></script>





  

</div>

    </div>

  </div>

</div>

<div class="ui modal">
  <div class="content">
    <!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:400px;}
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//westernnews.us12.list-manage.com/subscribe/post?u=ad9bbcca1da2e5673f9a3e417&amp;id=c3591abb2d" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2>Subscribe to our mailing list</h2>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group">
	<label for="mce-FNAME">First Name </label>
	<input type="text" value="" name="FNAME" class="" id="mce-FNAME">
</div>
<div class="mc-field-group">
	<label for="mce-LNAME">Last Name </label>
	<input type="text" value="" name="LNAME" class="" id="mce-LNAME">
</div>
<div class="mc-field-group input-group">
    <strong>Websites </strong>
    <ul><li><input type="checkbox" value="1" name="group[11509][1]" id="mce-group[11509]-11509-0" checked><label for="mce-group[11509]-11509-0">  williamsnews.com</label></li>
<li><input type="checkbox" value="2" name="group[11509][2]" id="mce-group[11509]-11509-1" checked><label for="mce-group[11509]-11509-1">  grandcanyonnews.com</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ad9bbcca1da2e5673f9a3e417_c3591abb2d" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->
  </div>
</div>



<script>

	$('.menu .item')

		.tab();

  $('.ui.modal').modal('attach events', '.newsletter.button', 'show');
</script>





                

                  

                    

                  

                

              </div>

            

            

            

          

        </div> 

      

<div class="flex justify-center">

  <!-- /187193454/gcn_lb_btf -->

<div id='div-gpt-ad-1478282699440-1'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478282699440-1'); });

</script>

</div>

</div>

<div class="flex justify-center bottom-mobile-leaderboard">

  

</div>

<div class="flex justify-center">

  <!-- /187193454/gcn_mb_footer -->

<div id='div-gpt-ad-1473351531487-4' style='height:310px; width:310px; text-align:center; margin:0 auto;'>

<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1473351531487-4'); });

</script>

</div>

</div>



      </div> 

      

      

    

    </div> 

  </div>  

    

  <div id="main-footer" class="footer ui centered grid">

  <div class="footer__columns seven column doubling row">

    <div class="footer__search three wide column has-text-centered">

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input" autocomplete="off">

          <input type="text" name="q" value="">

          <i class="search icon"></i>

        </form>

      </div>

      <div class="footer__logo">

        

          <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/grandcanyonnews/logos/footer-logo.png" alt="footer logo" class="ui fluid image"/>

        

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SECTIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/news/news/">News</a></div>

        <div class="item"><a href="/news/opinion/">Opinion</a></div>

        <div class="item"><a href="/news/sports/">Sports</a></div>

        <div class="item"><a href="/news/features/">Features</a></div>

        <div class="item"><a href="/news/milestones/">Milestones</a></div>

        <div class="item"><a href="/news/obituaries/">Obituaries</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">CLASSIFIEDS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/classifieds/">Main</a></div>

        <div class="item"><a href="/classifieds/category/local-employment/">Jobs</a></div>

        <div class="item"><a href="/classifieds/category/autos-and-vehicles/">Cars</a></div>

        <div class="item"><a href="/classifieds/category/real-estate/">Real Estate</a></div>

        <div class="item"><a href="https://classifiedsplacement.westernnews.com/williamsnewsui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a></div>

        <div class="item"><a href="/about/">About Us</a></div>

        <div class="item"><a href="/contact/">Contact Us</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">EVENTS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/events/">Today's Events</a></div>

        <div class="item"><a href="/events/search/">Search Events</a></div>

        <div class="item"><a href="/submit-event/">Submit Event</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SUBMISSIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/contact/">Submit a News Tip</a></div>

        <div class="item"><a href="/submit/birth-announcement/">Birth</a></div>

        <div class="item"><a href="/submit/engagement-wedding-announcement/">Wedding <br> Engagement</a></div>

        <div class="item"><a href="/contact/">Website Feedback</a></div>

        <div class="item"><a href="/subscriber-services/">Subscriber Services</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">PROFILE</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/users/newsletters/">Newsletter</a></div>

      </div>

    </div>

  </div>

  <div class="one column row">

    <div class='copyright'>

      

        <p class="has-text-white"><span>Contents of this site are &copy; Copyright 2019 Grand Canyon News and Western News&amp;Info&reg;, Inc. All rights reserved. | </span><a href="/terms-of-service/" class="has-text-white"> Terms of Service</a> | <a href="/privacy-policy/" class="has-text-white">Privacy Policy</a></p>

      

    </div>

  </div>

</div>



  

<script>

	$('.menu .item')

		.tab();

  $('.ui.modal').modal('attach events', '.newsletter.button', 'show');
</script>


    

  <script src="https://cdn.syncronex.com/libs/v1.9/syncLoginSdk.js"></script>

  <script>

    function setView (status) {

      var login = document.getElementById('sync-login-status');
      var mobileSubscribe = document.getElementById('mobile-subscribe');
      var myaccount = document.getElementById('sync-login-myaccount');

      var logout = document.getElementById('btnLogout');

      var logoutContainer = document.getElementById('logoutContainer');

      var subscribeNow = document.getElementById('subscribe-now');

      if (status === 'loggedIn') {

        myaccount.textContent = ' My Account';

        myaccount.href = "https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=WGCN";

        login.style.display = 'none';
        mobileSubscribe.style.display = 'none';

      } else if (status === "notLoggedIn") {

        subscribeNow.style.display = 'inline-block';

        myaccount.style.display = 'none';

        logoutContainer.style.display = 'none';

        login.href = "https://subscribe.williamsnews.com/wn/wgcn/Account/LogOn?ReturnUrl=https://grandcanyonnews.com/news/2019/dec/27/snow-showers-continue-through-saturday/";

        login.textContent = ' Log In';

      }

    }

    var sdk = window.syncLoginSdk;

    sdk.applicationOrigin = 'https://subscribe.williamsnews.com';

    sdk.debug = true;

    sdk.apiTimeout = 5000;

    sdk.sessionExpireDays = 30;

    sdk.requireLegacyLogin = true;

    sdk.tenantId = 'wn-wgcn';

    // getLoginStatus takes two parameters - the first is a success callback, the second is a failure callback

    sdk.getLoginStatus(function(data) {

      setView("loggedIn");

    }, function(errStatus) {

      setView("notLoggedIn")

    })

    var btnLogout = document.getElementById('btnLogout');

    btnLogout.addEventListener('click', function(e) {

      sdk.logOut(function() {

        window.location.reload();

      }, function() {

        alert('Log out failed.');

      });

    })

  </script>


  <script>

    $('.ui.sidebar-nav')

    .sidebar('attach events', '.show-side-nav-button');

    $('.top-more-menu')

    .sidebar({

      transition: 'push',

    })

    .sidebar('attach events', 'div.more-menu');

  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify.min.js?v=7"></script>  

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify-jquery.min.js?v=8"></script>

  <script>

     // turn plain text links into hyperlinks

    $('p').linkify();

    $('#sidebar').linkify({

      target: "_blank"

    });

  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/word_limit.js?v=7" async></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/westernnews.js?v=18" async></script>

</body>

</html>
